Intermitencias en Banco Falabella
Incident Report for khipu
Resolved
This incident has been resolved.
Posted May 08, 2020 - 16:34 GMT-04:00
Identified
The issue has been identified and a fix is being implemented.
Posted May 07, 2020 - 16:26 GMT-04:00
This incident affected: Bancos.