Banco Itaú con intermitencias
Incident Report for Khipu
Resolved
Incidente resuelto.
Posted Aug 07, 2021 - 17:17 GMT-04:00
Monitoring
La página web de Banco Itaú no se encuentra disponible.

Recomendamos a los pagadores preferir otro banco.
Posted Aug 07, 2021 - 14:29 GMT-04:00
This incident affected: Bancos.