Banco Santander presenta intermitencias

Incident Report for Khipu

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 12:23 GMT-03:00

Investigating

Estamos monitoreando el estado de Banco Santander
Posted Nov 24, 2025 - 17:24 GMT-03:00